In wich templates NGE is usable?

More
5 years 9 months ago #3912 by jmbouille
jmbouille created the topic: In wich templates NGE is usable?
NGE (NextGen Editor) can be used in most Joomla template.
We have tested NGE in common templates :
- Joomla native (protostar, beez)
- T3
- Gantry
- Yootheme

In some templates, some capabilities are not yet available. For example in a Yootheme template the module editing is not possible.
We are trying progressively to make NGE be functionnal in all known templates.

Please tell us if you have problems with a particular template.
The following user(s) said Thank You: ssnobben

Please Log in or Create an account to join the conversation.

More
5 years 9 months ago #3921 by ssnobben
ssnobben replied the topic: In wich templates NGE is usable?
Great will test this later. You are using Jquery and any other javascrip as well? What bother me is the javascript conflict issues that hopefully are gone now for Joomla when dumping mootools..

I see a lot of progress everywhere now with different jquery
packery.metafizzy.co/
isotope.metafizzy.co/ etc

Please Log in or Create an account to join the conversation.

More
5 years 9 months ago #3924 by jmbouille
jmbouille replied the topic: In wich templates NGE is usable?
We use very widely jquery. I think it is not a problem. It is stable, and the library spread is generally always the same and not modified.
It is a good thing to dump mootols in Joomla. I had compatibilities problems with mootols and a slider library i wanted to use : bxslider. I had to choose another one (jssor).
We had also some issues with mootools and jQueryui that we use for draging and moving the parts in the page. If I could find another solution, I would prefer not to use jqueryui.
At that time, we didn't have problems with javascript conflicts, even if we use some external libraries.

The main problem in our project is the utilization of bootstrap, where we encounter more various versions js and css. For example the bootstrap css included in Joomla is not the same as the standard version, and in many templates we encounter other versions, and also version 3 (that is a very good thing).
We plan to use our own bootstrap.js, with the help of requirejs, that would ensure we don't have compatibility problems.
Our widgets components (the "parts"), follow by default the current bootstrap css that can be very different in the templates. In theory it is a good thing, in pratice it can cause some issues.

Please Log in or Create an account to join the conversation.

More
5 years 9 months ago #3925 by ssnobben
ssnobben replied the topic: In wich templates NGE is usable?
Hi I tried to find how to message to you directly but you didnt set up forum to allow this.

Maybe this from Joomla UK day could be interesting for you if you have not already listening to it.
The following user(s) said Thank You: jmbouille

Please Log in or Create an account to join the conversation.

More
5 years 9 months ago #3929 by jmbouille
jmbouille replied the topic: In wich templates NGE is usable?
Thank you for the the video!
The setup of the forum is not compete. I will try to allow private messages.

my email is This email address is being protected from spambots. You need JavaScript enabled to view it.

Please Log in or Create an account to join the conversation.

Powered by Kunena Forum