Impossible to use NGE - Error after installation

More
4 years 6 months ago #3994 by NosyWeb
NosyWeb created the topic: Impossible to use NGE - Error after installation
Hello,

I installed the last version of NGE and I have this error :
Avertissement

SELECT p.id, p.part as name, p.title, p.alias, p.content, p.params, p.html, p.css, p.js, p.thumbnail, p.published, p.created, p.created_by, l.title as library_title, l.description as library_description, pl.version, l.params as library_params FROM #__nge_parts AS p LEFT JOIN #__nge_parts_library AS l ON l.part = p.part LEFT JOIN #__nge_categories AS cat ON cat.id = l.catid LEFT JOIN #__nge_plugins AS pl ON pl.name = cat.plugin WHERE l.state = 1 AND p.published = 1 AND p.id =28

NGE_APPLICATION_ERROR_PARTS_LOAD

SELECT p.id, p.part as name, p.title, p.alias, p.content, p.params, p.html, p.css, p.js, p.thumbnail, p.published, p.created, p.created_by, l.title as library_title, l.description as library_description, pl.version, l.params as library_params FROM #__nge_parts AS p LEFT JOIN #__nge_parts_library AS l ON l.part = p.part LEFT JOIN #__nge_categories AS cat ON cat.id = l.catid LEFT JOIN #__nge_plugins AS pl ON pl.name = cat.plugin WHERE l.state = 1 AND p.published = 1 AND p.id =20

PHP 7.0.19 / Joomla 3.7.1 / NGE 1.1.1

Thanks for your help.

Regards.

Please Log in or Create an account to join the conversation.

More
4 years 6 months ago #3995 by jmbouille
jmbouille replied the topic: Impossible to use NGE - Error after installation
Hi,
is it a new installation or an update from a previous versionof NextGen Editor?
It seems some fields are missing in the #_nge_parts table.
Is it possible for you to execute in mysql the SELECT that makes the error?

SELECT p.id, p.part as name, p.title, p.alias, p.content, p.params, p.html, p.css, p.js, p.thumbnail, p.published, p.created, p.created_by, l.title as library_title, l.description as library_description, pl.version, l.params as library_params FROM #__nge_parts AS p LEFT JOIN #__nge_parts_library AS l ON l.part = p.part LEFT JOIN #__nge_categories AS cat ON cat.id = l.catid LEFT JOIN #__nge_plugins AS pl ON pl.name = cat.plugin WHERE l.state = 1 AND p.published = 1 AND p.id =28

Please Log in or Create an account to join the conversation.

More
4 years 6 months ago #3996 by NosyWeb
NosyWeb replied the topic: Impossible to use NGE - Error after installation
Hi Jean-Marc :-),

It is a new installation.
I executed your query, it returns :
#1054 - Unknown column 'p.html' in 'field list'

Thanks for your help.

Regards.

Please Log in or Create an account to join the conversation.

More
4 years 6 months ago #3997 by NosyWeb
NosyWeb replied the topic: Impossible to use NGE - Error after installation
I attached the tables.

File Attachment:

File Name: tables.zip
File Size:8 KB
Attachments:

Please Log in or Create an account to join the conversation.

More
4 years 6 months ago #3998 by jmbouille
jmbouille replied the topic: Impossible to use NGE - Error after installation
Ok, I think the problem is you already installed an old version of NextGen Editor, and a mysql table remained after desinstallation.

Have have fixed this case in the next version 2.0 that will be released very soon (I think tomorrow).

Right now, you can uninstall all the extension (1.1.1), it will destroy all tables, then install again the extension. It should work.

Please Log in or Create an account to join the conversation.

Powered by Kunena Forum