Problems with Joomla 3.8

More
2 years 8 months ago #4022 by jmbouille
jmbouille created the topic: Problems with Joomla 3.8
If you update your current Joomla version to the lastest : 3.8 (available since 2 days), you will get some problems:
- editing the page in frontend (inline-editing) is not possible : a error message is displayed.
- in the current editor (Ark, Jce, Tinymce), in the config window of a widget, the preview is not working.

There is not any problem in the normal displaying of the pages and the widgets in the website.

Somes changes have been made in Joomla! in this version 3.8.(Files moved, preparing Joomla 4).

We have fixed the problem. A update will be published tomorrow the 22th October.
This update will contain some new features that have been prepared during the summer time.

Please Log in or Create an account to join the conversation.

More
2 years 7 months ago #4023 by trimazo
trimazo replied the topic: Problems with Joomla 3.8
Bonjour,

Voici les messages d'erreur reçus sous joomla 3.8 :

en éditant un module créé avec NGE 1.0.2

Warning: require_once(/volume1/web/sitetest/libraries/joomla/utilities/utility.php): failed to open stream: No such file or directory in /volume1/web/sitetest/plugins/system/nge_system/modules/positions.php on line 95 Fatal error: require_once(): Failed opening required '/volume1/web/sitetest/libraries/joomla/utilities/utility.php' (include_path='.') in /volume1/web/sitetest/plugins/system/nge_system/modules/positions.php on line 95

en ligne sur la page d'accueil à la place du titre NGE
Avertissement
SELECT p.id, p.part as name, p.title, p.alias, p.content, p.params, p.html, p.css, p.js, p.thumbnail, p.published, p.created, p.created_by, l.title as library_title, l.description as library_description, pl.version, l.params as library_params FROM #__nge_parts AS p LEFT JOIN #__nge_parts_library AS l ON l.part = p.part LEFT JOIN #__nge_categories AS cat ON cat.id = l.catid LEFT JOIN #__nge_plugins AS pl ON pl.name = cat.plugin WHERE l.state = 1 AND p.published = 1 AND p.id in("11", "50", "48", "47", "14", "15")
NGE_APPLICATION_ERROR_PARTS_LOAD

Tout ceci ce passe sur un site de test. Le site en ligne est aussi en joomla 3.8 et les modules NGE 1.0.2 s'affichent correctement.

Merci pour ce travail remarquable !
Cordialement

Please Log in or Create an account to join the conversation.

More
2 years 7 months ago #4024 by jmbouille
jmbouille replied the topic: Problems with Joomla 3.8
Hello, thanks for the informations. If you are not logged as administrator in your production website, Joomla 3.8 does not make any problem with NGE. A new version with corrections should be published this week-end.

Bonjour.
Merci pour ces informations.
Je pense que sur le site de test, vous êtes logués en administrateur, d'où les messages d'erreur.
Sur le site en ligne, je suppose que vous n'êtes pas logués, donc ça se passe bien.
Je suis en retard pour mettre en ligne une vesion corrective. Cela devrait être le cas ce week-end.
Il y a eu beaucoup de changements depuis la dernière version, et j'ai du faire beaucoup d'ajustements.

Merci pour vos encouragements. Par rapport à la version 1.0.2, une version 2.0 a été mise en ligne en juin, et ce week-end une version 2.1. Vous constaterez énormément d'évolutions.
Je n'ai pas beaucoup de retour de la part de nos utilisateurs. N'hésitez pas à faire des remarques ou des demandes sur le forum.
The following user(s) said Thank You: trimazo

Please Log in or Create an account to join the conversation.

More
2 years 7 months ago #4025 by trimazo
trimazo replied the topic: Problems with Joomla 3.8
Bonjour et merci pour votre réponse,

Voici ce que je vois
sur le site de test sans connexion :
testsite.dyndns.org/ joomla 3.8 nge 2.0
sur le site en ligne sans connexion :
trimazo.is-a-musician.com/ joomla 3.8 nge 1.0.2

Cela doit être plus parlant et pourra peut-être vous aider

Encore un grand merci pour ce magnifique module.

Cordialement

DR

Please Log in or Create an account to join the conversation.

More
2 years 7 months ago #4031 by Bmzen
Bmzen replied the topic: Problems with Joomla 3.8
bonjour,
J'utilise la version free et après la mise à jour en ligne je me suis aperçu que la preview fonctionnait plus. les points de couleurs tournent comme si elle chargeait mais très longtemps sans résultat. Plus difficile pour mettre en forme. En plus j'ai réinstallé pensant que cela provenait d’une mauvaise installation et une partie de mon texte a disparu. Et on s'y fait bien à NGE, Ça rend les choses facile pour les débutants comme moi alors quand cela ne fonctionne plus nous sommes perdus. Et encore je suis certain que je n’utilise pas toutes les fonctionnalités. Je dis bravo en tout cas.
Marc

Please Log in or Create an account to join the conversation.

More
2 years 7 months ago #4032 by trimazo
trimazo replied the topic: Problems with Joomla 3.8
Bonjour,

Je suis passé à joomla 3.8.1 et mes problèmes persistent mais avec quelques évolutions :

En backend, le message :

Warning: require_once(/volume1/web/sitetest/libraries/joomla/utilities/utility.php): failed to open stream: No such file or directory in /volume1/web/sitetest/plugins/system/nge_system/modules/positions.php on line 95 Fatal error: require_once(): Failed opening required '/volume1/web/sitetest/libraries/joomla/utilities/utility.php' (include_path='.') in /volume1/web/sitetest/plugins/system/nge_system/modules/positions.php on line 95

ne s'affiche plus depuis que j'ai remplacé /joomla/utilities/utility.php par /src/Utility/Utility.php dans positions.php mais je n'arrive toujours pas à éditer d'anciens éléments

Maintenant, je peux créer de nouveaux éléments. Le plus surprenant est que les éléments créer en frontend ne sont éditables que dans ce mode et réciproquement en backend.

En créant ces nouveaux objets, je me suis aperçu que les posibilités de mises en page (mes essais ne concerne que des titres) sont moins nombreuses que dans la version 1.0.2 de NGE. La bordure du titre est toujours complète sur les 4 cotés et il n'y a plus de possibilité de center le titre ou d'arrondir les angles.

J'espère que mes observations vous serons utiles et merci encore pour ce bel outil.

Cordialement

DR

Please Log in or Create an account to join the conversation.

More
2 years 7 months ago #4033 by trimazo
trimazo replied the topic: Problems with Joomla 3.8
Bonjour,

Plein d'espoir, j'ai installé la nouvelle version 2.1.0 et je viens de constater que les éléments (titres, panels ,etc) créés avec la version 1.0.2 ne sont plus visibles en frontend et ne sont pas éditables en backend.
Déception et désespoir ! Heureusement c'est sur mon site de test et comme j'ai créé beaucoup d'éléments le site en ligne va resté en version 1.0.2.
Auriez-vous une solution?
Cordialement
DR

Please Log in or Create an account to join the conversation.

More
2 years 7 months ago #4034 by jmbouille
jmbouille replied the topic: Problems with Joomla 3.8
Hello, I have published today a new release. It works well with Joomla 3.8.0 and 3.8.1. It contains many improvments, especially since the 1.0.2 version. You tell me the widgets you created with the 1.0.2 are not visible after the 2.1.0 installation. I am trying immediately to understand why.

Bonsoir, je viens de mettre en ligne cette nouvelle version, et je vais donner plus d'explications dans le forum et la documentation. Elle résoud bien entendu les problèmes rencontrés sous Joomla 3.8.1.
Il est bien évident que normalement tout ce qui a été créé auparavant avec la version 1.0.2 ne devrait pas avoir disparu.
Je cherche immédiatement la raison de ce problème.
Cette nouvelle version 2.1.0 contient énormément d'améliorations et de modifications internes. J'ai mis plus d'un an à la mettre au point et la stabiliser, sachant qu'elle contient désormais beaucoup de fonctions avancées.
Je vais essayer de comprendre ce qui peut bloquer, en consultant votre site.
Si j'ai besoin je vous demanderai sûrement votre aide pour que vous me transmettiez peut-être directement des exemples de widgets.

Please Log in or Create an account to join the conversation.

Powered by Kunena Forum